Workflow problem - Failed to load the workflow

Aug 12, 2008 at 9:14 PM
Edited Aug 12, 2008 at 9:18 PM
Hello,

I downloaded this Employee Training Template so that it would fix the available seats if user registers or unregister the course And users dont need contribute access to be able to register and be able to edit the items.

However, I am having problems with workflow - I saw the notice on the page to bind the workflow by clicking Finish on the wizard. But When I open the sharepoint desinger and click on registration workflow  and un registration workflow - it says "failed to load the workflow". I followed all of the steps on readme file.

Which web.config file do I need to add this code to?  Because I added on c:/inetpub/wwwroot one .. what is the file  location to be exact?
  <authorizedType Assembly="Sogeti.Workflow.Activities,  Version=1.0.0.0, Culture=neutral, PublicKeyToken=1cdaea2144644b9c"
    Namespace="Sogeti.Workflow.Activities" TypeName="*" Authorized="True" />

When I registered the avaialble seat does not get updated And I am not able to Remove from course.. Its Not working at alll.... Please help???

Thanks
Aug 17, 2008 at 10:38 PM
The web.config that you need to edit is the one that is hosting your SharePoint site.   In most cases this is C:\Inetpub\wwwroot\wss\VirtualDirectories\80\web.config.

The error that you are seeing indicates that either the assembly (DLL) wasn't placed in the global assembly cache, the web.config file was not updated or the Sogeti.actions file was not placed in the correct location.

In most cases after you make changes to the web.config file the application pool will restart.  You can run an IISRESET command to force a complete restart which will load the changes made to the web.config file.

Feb 26, 2009 at 11:43 AM
Edited Feb 26, 2009 at 11:43 AM
Hello,

I followed to manual but just like sara, I can't get it to work.
I follwed the instructions but when registrating and unregistrating I get the following error on the workflow: Failed on Start (retrying)

As you can see on the image below I put everything (I think) in the right place.
http://img24.imageshack.us/my.php?image=2262009115842am.png

Do you have any ideas what I do wrong , and how to fix it?

Thanks
Apr 15, 2009 at 1:30 PM
I am having the exact same problems as the others. The Failed to Start (retrying) error comes up for me as well, and I am an owner of the site, so I should have all the permissions I need.
Apr 15, 2009 at 2:10 PM
I have someone looking into the issue and will post an update as soon as possible.
Apr 15, 2009 at 2:33 PM
Excellent...we would love to roll with this module in our organization right now.
May 6, 2009 at 1:50 AM
I get a "Failed to load the workflow" error in Sharepoint Designer.  Any news on these error messages?
May 6, 2009 at 3:07 PM
I was working on the site and everything seems to be working fine.  Please make sure when you copy the dll into the assembly that you do "iisreset",  and make sure that the user who register and unregister have Contribute Rights on the site.

Let me know if this worked for you, If not can you please send me a screen shot of the error.

Thank you,
Mark Chaaban
May 6, 2009 at 4:07 PM
I did what you had suggested but it still doesn't seem to to work.  I keep seeing Failed on Start in the Registrations list and Failed to load the workflow in Sharepoint designer.


May 6, 2009 at 5:11 PM
The Instructor reminder works but the Registration/UnRegistration do not work.  (Failed On Start)
May 7, 2009 at 11:03 PM
I also have the same exact issue. The instructor reminder works, but the Registration/Unregistration does not work. If someone out there knows how to solve this, it would REALLY be appreciated. Our platform is server 2008 and I had to do a lot of other things to get this far, and now I just need these reminders to work. I would just recreate the workflows myself, but I am not sure what all info was used to create the workflows. Someone please help...
May 11, 2009 at 2:39 PM

Server 2003 with MOSS 2007 here...still not working. Completely removed and reinstalled the module to no avail. Any other updates?

May 12, 2009 at 4:36 PM

I'm working on the problem,  I will post an update very soon.

<input id="gwProxy" type="hidden"><!--Session data--></input><input id="jsProxy" onclick="jsCall();" type="hidden" />

May 12, 2009 at 4:41 PM

That would be Outstanding! We are going to use this in our company and our training ladies are on me to try and get this fixed. You would be a hero in my eyes! :)

May 26, 2009 at 5:13 PM

mchaaban, Did you ever get a chance to get this template working? I know you were working on a solution and we were wondering if you made any progress yet. Please help if you can. Thanks

May 26, 2009 at 7:25 PM

I worked on it last week and I couldn't get it to work,  currently I'm seeking help from the consultant that was working on it previously. as soon I get a respond I will post it.

Sorry for the delay,

Mark Chaaban

May 26, 2009 at 7:39 PM

Okay. Thanks for the update. I was just checking in to see if you were still working on it. Once again, I would like to thank you for doing this for us. This will be a big help in our organization.

Jun 1, 2009 at 4:15 PM

The code is good to go, you need to add everyone to the Site Members so they have Contribute Access to the site, and change the permissions for the Site Members of the Course List to Read Only.  This should fix the problem. 

I updated the Readme.txt file.

Please try this and let me know if you are still having problems.

Thank you,

Mark Chaaban

 

Jun 1, 2009 at 4:59 PM

Mark,

The only workflow that works is the Instructor reminder workflow. Both of the other two workflows still do not work. If I try to load the Attendee registration or the Attendee unregistration workflow, I still get the "Failed to load the workflow". Also, if I look at the Registrations workflows, I still see "Failed on Start (retrying)". Both of those workflows are the heart to this template. If I knew exactly what all was in them, I might could re-create them, but I am not sure what all is in there. Have you tried to load either of those two workflows yourself? If so, do you get the same error?

Jun 1, 2009 at 6:35 PM

I checked all the workflows, I was able to Register/Unregister for all users with different permissions.  Please unistall everything and follow the instruction in the Readme.txt file. 

Thank you,

Mark Chaaban

Jun 1, 2009 at 8:16 PM

mchaaban,

I uninstalled all modules associated with this template, restarted IIS services on the system, then reinstalled per instructions, and again restarted IIS services.

I set the permissions as described, I can register for the course (I am a site owner), but I still cannot unregister from the course - Failed on Start (retrying).

Please advise.

 

 

Jun 1, 2009 at 8:27 PM

I'm going to deploy a solution with the steps needs to be taken. check back later tonight.  Thanks Mark

Jun 1, 2009 at 8:40 PM
Edited Jun 1, 2009 at 8:44 PM

I found the following as well...looking at the attendee unregistration workflow status, i see the following:

Date Occurred
Event Type

User ID
Description
Outcome
6/1/2009 3:32 PM Error
System Account
Attendee unregistration failed to start.

I did a search on the error, and found this:

Workflow "Error" System Account An error has occurred after workflow completed MOSS 2007

Problem: If you have a "built in" or custom approval workflow setup for your document library. The workflow runs correctly, however when sometimes you look at the workflow status, you may receive an error after the task has been approved and completed such as, Event Type: Error User ID: System Account Description: An error has occurred in [name of workflow].
Resolution: When you define your workflow, there is a section "Post-completion Workflow Activities", where you can check "Update the approval status (use this workflow to control content approval)". If you check this option, and you do NOT have content approval enabled on the library level, you get the system account error message. If you do not check it, everything works fine.
Reason for occurrences: The account listed in the "User ID" column does not have permission to "something" that is being requested in the workflow code. Workflow usually running as the "system account" within SharePoint and should have access to all the objects within SharePoint. However, the system account may not have access to some resources that are outside of SharePoint and needed by the workflow code. Accessing outside resources is usually done via the .NET worker process account (e.g. NETWORK SERVICE).

Not sure if that will help or not, but that's what I'm seeing.
Jun 1, 2009 at 10:01 PM

After reading your posts, I somehow got this template to work (so far)(I havent finished fully trying everything yet). First, I don't know if I needed to, but I gave the built in system account full control on my site. I then noticed that the workflow was failing due to a lack of authorization. I got this from the log file on our sharepoint server (C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\logs). <Error><CompilerError Line="0" Column="0" Text="Type Sogeti.Workflow.Activities.UpdateListItem, Sogeti.Workflow.Activities, Version=1.0.0.0, Culture=neutral, PublicKeyToken=1cdaea2144644b9c is not marked as authorized in the application configuration file." /></Error> I looked in our web.config file and somehow, this is what I had... <authorizedType Assembly="Sogeti.Workflow.Activities, &#xD;&#xA;    Version=1.0.0.0, Culture=neutral, PublicKeyToken=1cdaea2144644b9c" Namespace="Sogeti.Workflow.Activities" TypeName="*" Authorized="True" /> I have no idea why it added the underlined part. When the above line was added, i just copied and pasted from the readme file. I removed this and now I can open all of the workflows in sharepoint designer and it appears that the workflows run. I am going to continue to test this tomorrow. I am about to take it to the house for the day. I will post any more updates later.

Jun 2, 2009 at 4:53 PM

It appears to me that The unregiser worklow and the instructor reminder workflow works fine. The register workflow is now the one giving me fits. It appears that it goes through the workflow just fine until it gets to the part where it emails a submit feedback email after the class has happened. The email never sends out and the task is "In Progress". The task is labeled as "paused for 128.longnumber minutes. It seems to me that the countdown never moves. It always has the same amount of pause time. Since that is paused, the last step in the workflow which is moving the registrations to past registrations never occurs. I guess as a last resort, I can try to reinstall the template again, but if yall have any suggestions before I do, they would be greatly appreciated.

Feer, did you ever get yours to work?

Mchaaban, thanks for all the time you have put into making this happen for us.

 

Michael

Jun 2, 2009 at 6:51 PM

Nevermind. Scratch that. The pause time is apparently 2 hours after the class is over. If you check the status, it doesn't move until it ends. Everything is working here. Thanks to everyone envolved for your help.

Jun 2, 2009 at 8:16 PM

msprad

I attempted to follow your same line of thinking with this, but I never did see the error in the web config, or my log file. I'd appreciate any help you could provide. I'm glad you got this working...I'd like to follow in your footsteps :-)

Sep 16, 2010 at 3:48 PM

I noticed that the last post on here was made almost a year and a half ago, but I followed the instructions on this sheet verbatim and I'm still having problems with the Attendee Registration and Attendee Unregistration workflows either failing to load in SharePoint Designer, or activating correctly when they're triggered.  Has somebody found a successful workaround they can point me to?

Oct 17, 2011 at 6:25 PM
Edited Oct 19, 2011 at 9:13 PM

After frustrating hours, I found this posted in the release notes and this fix it.

NOTICE: In some installations the workflows do not bind correctly to the lists in the template. If the workflows do not appear to be functioning, use SharePoint Designer to open the 3 seperate workflows in the site and then click on the finish button in the workflow wizard. This will rebind the workflows to the lists correctly. We are currently trying to identify the root cause of this issue.

The note below may still apply to some installations?

The problem that most users are reporting (system account not running workflow) occurs because of a change by MS. The attached KB explains it.

http://support.microsoft.com/kb/947284

for further information:

http://blogs.msdn.com/b/sharepointdesigner/archive/2008/09/28/declarative-workflows-and-user-context.aspx